Support Centre

Find articles, help and advice.

 
Welcome, Guest Login

Support Center

SCM - "Unable to find an available driver" error during CMDB Setup

Last Updated: Nov 13, 2015 11:45AM UTC
Problem

"Unable to find an available driver for: DB Type" error thrown when running the CMDB Setup.



Cause

There are two potential causes to this issue:

1. The database drivers are not installed or available on the server.
2. You are not running the correct version of the CMDB Setup script for the architecture of your system.

Solution

Firstly, ensure that you are running the correct version of the CMDB Setup script for the architecture of your system i.e. CMDBSetup for 32-bit systems and CMDBSetup64 for 64-bit systems.

If you continue to see the error during setup, the solution is to install the Bridge Server before running the CMDB Setup. During the Bridge Server install, all of the supported database drivers are installed. Once the Bridge Server is installed, the CMDB Setup should then find the available driver and complete the CMDB setup.

Contact Us

desk.com@interlinksoftware.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete