Support Centre

Find articles, help and advice.

 
Welcome, Guest Login

Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

EventDaemon waiting for ASConnection to initialise

Mathew Allbright Feb 07, 2014 08:06AM UTC

Morning

We have installed Sybase 15.5 and BES 3.6 on a new Solaris 10 server. Whilst the install process was OK, I am unable to get the 'Service_Dashboard' system via the web client (admin console works fine) as getting:

Error = System.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, version=2.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.
at ISS.BES.Dashboard.DotNETConsole.Console.Constructor(Boolean useFixedWidthFont, Boolean showMethodNames)
at ISS.BES.Dashboard.DotNETConsole.Console..ctor()
The action that failed was:
LinkDemand
The type of the first permission that failed was:
System.Security.Permissions.SecurityPermission
The Zone of the assembly that failed was:
Intranet.

I think this has something to do with my Internet Security settings on my PC which I cannot amend as I do not have admin rights. Are you able to confirm this though?

Additionally, the following is being constantly written to the POWERpack_Log

EventDaemon waiting for ASConnection to initialise
EventDaemon waiting for ASConnection to initialise
EventDaemon waiting for ASConnection to initialise
Unable to connect to AlertServer - Retry in 10 seconds

Up 4 rated Down
Matthew Sweeney Feb 07, 2014 12:30PM UTC Interlink Software Agent
MS: Hi Mathew,

Yes, this is down to the security settings in your web browser. You need to ensure the following settings are applied on your PC:

1. .NET framework installed
2. Installed and run the latest TrustInterlinkSoftware.exe as Administrator
3. Added the BES URL to the Local Intranet zone on IE? To do this go to Internet Options -> Security tab -> Local Intranet -> Sites -> Advanced then add the URL, you will need to restart IE after this.
4. Added 'EnableIEHosting' key in your registry in the following location: HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > .NETFramework

Could you also try setting these security settings for the Intranet zone.

Step 1. On a Microsoft Windows host, open an Internet Explorer.
Step 2. From the menu bar, choose Tools => Internet Options to open the Options dialog box.
Step 3. Click the Security tab to bring it to the forefront.
Step 4. In the zone box, select Local Intranet and click Custom Level to open the Security Settings dialog box.
Step 5. Select Enable for everything under “.NET Framework‐reliant components”.
Step 6. Select Enable for everything under “ActiveX controls and plug‐ins”.
Step 7. Click OK to close the Options dialog box.
Step 8. Close the Internet Explorer to ensure that the option changes are retrieved the next time Internet Explorer is opened.


With regards to the errors logged in the POWERpack_Log, can you try a telnet to the AlertServer:

telnet localhost 40000

This should connect you to the AlertServer and display a list of options.

Regards,
Matthew
Up 1 rated Down
Grant Glading Feb 07, 2014 03:47PM UTC
Does that mean you add the 'EnableIEHosting' key in your registry in the following location: HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > .NETFramework

Should 'EnableIEHosting' key have a value set?
Up 0 rated Down
Colin Griffiths Feb 07, 2014 04:00PM UTC
Yes 'EnableIEHosting' key should have a DWORD value of 1.

This question has received the maximum number of answers.

Contact Us

desk.com@interlinksoftware.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete